Difference between revisions of "Downloads"

From Wiki for iCub and Friends
Jump to: navigation, search
(Windows)
(Update Windows binaries to point to the 1.8.0 version)
Line 1: Line 1:
 
Latest releases:
 
Latest releases:
* 29/11/2016 : '''iCub-1.6.0''', requires '''YARP-2.3.68'''
+
* 15/06/2017 : '''iCub-1.8.0''', requires '''YARP-2.3.70'''
  
 
Previous releases:
 
Previous releases:
 +
* 29/11/2016 : iCub-1.6.0, requires YARP-2.3.68
 
* 01/06/2016 : iCub-1.4.0, requires YARP-2.3.66
 
* 01/06/2016 : iCub-1.4.0, requires YARP-2.3.66
 
* 18/06/2015 : iCub-1.1.16, requires YARP-2.3.64
 
* 18/06/2015 : iCub-1.1.16, requires YARP-2.3.64
Line 15: Line 16:
  
 
== Windows ==
 
== Windows ==
[[Image:win-logo.jpg|right|50px]] '''Important''': to develop code using precompiled binaries packages have to match the compiler you use, make sure you download and install the correct version (i.e. MSVC11 x86 for Visual Studio 2012 32 bit, MSVC12 amd64 for Visual Studio 2013 64 bit etc.).
+
[[Image:win-logo.jpg|right|50px]] '''Important''': to develop code using precompiled binaries packages have to match the compiler you use, make sure you download and install the correct version (i.e. MSVC12 x86 for Visual Studio 2013 32 bit, MSVC14/15 amd64 for Visual Studio 2015/2017 64 bit etc.).
  
 
If in doubt about the version number of your copy of Visual Studio, find the internal version number shown for it in this [https://en.wikipedia.org/wiki/Microsoft_Visual_Studio#History version history table].
 
If in doubt about the version number of your copy of Visual Studio, find the internal version number shown for it in this [https://en.wikipedia.org/wiki/Microsoft_Visual_Studio#History version history table].
Line 21: Line 22:
 
{| border="2" style="margin-left: 0em;"
 
{| border="2" style="margin-left: 0em;"
 
|-
 
|-
! iCub 1.6.0
+
! iCub 1.8.0
! scope="col" | MSVC 10
 
! scope="col" | MSVC 11
 
 
! scope="col" | MSVC 12
 
! scope="col" | MSVC 12
 +
! scope="col" | MSVC 14/15
 
! scope="col" | Sources
 
! scope="col" | Sources
 
|-
 
|-
 
! scope="row" | x86
 
! scope="row" | x86
| [https://github.com/robotology/icub-main/releases/download/v1.6.0/iCub_1.6.0_v10_x86_1.exe x86]
+
| [https://github.com/robotology/icub-main/releases/download/1.8.0/iCub_1.8.0_v12_x86_1.exe x86]
| [https://github.com/robotology/icub-main/releases/download/v1.6.0/iCub_1.6.0_v11_x86_1.exe x86]
+
| [https://github.com/robotology/icub-main/releases/download/1.8.0/iCub_1.8.0_v14_x86_1.exe x86]
| [https://github.com/robotology/icub-main/releases/download/v1.6.0/iCub_1.6.0_v12_x86_1.exe x86]
+
| [https://github.com/robotology/icub-main/archive/1.8.0.zip icub-main-src-1.8.0.zip]
| [https://github.com/robotology/icub-main/archive/v1.6.0.zip icub-main-src-1.6.0.zip]
 
 
|-
 
|-
 
! scope="row" | amd64
 
! scope="row" | amd64
| N/A
+
| [https://github.com/robotology/icub-main/releases/download/1.8.0/iCub_1.8.0_v12_x86_amd64_1.exe amd64]
| [https://github.com/robotology/icub-main/releases/download/v1.6.0/iCub_1.6.0_v11_x86_amd64_1.exe amd64]
+
| [https://github.com/robotology/icub-main/releases/download/1.8.0/iCub_1.8.0_v14_x86_amd64_1.exe amd64]
| [https://github.com/robotology/icub-main/releases/download/v1.6.0/iCub_1.6.0_v12_x86_amd64_1.exe amd64]
+
| [https://github.com/robotology/icub-main/archive/1.8.0.zip icub-main-src-1.8.0.zip]
| [https://github.com/robotology/icub-main/archive/v1.6.0.zip icub-main-src-1.6.0.zip]
 
 
|}
 
|}
  

Revision as of 14:47, 4 July 2017

Latest releases:

  • 15/06/2017 : iCub-1.8.0, requires YARP-2.3.70

Previous releases:

  • 29/11/2016 : iCub-1.6.0, requires YARP-2.3.68
  • 01/06/2016 : iCub-1.4.0, requires YARP-2.3.66
  • 18/06/2015 : iCub-1.1.16, requires YARP-2.3.64
  • 18/07/2014 : iCub-1.1.15, requires YARP-2.3.63
  • 06/08/2013 : iCub-1.1.13, requires YARP-2.3.22
  • 10/07/2013 : iCub-1.1.12, requires YARP-2.3.21
  • 04/03/2013 : YARP 2.3.20 binaries for windows 64bits
  • 7/12/2012 : iCub-1.1.11, requires YARP-2.3.20 (support for Visual Studio 11)
  • iCub-1.1.10, requires YARP-2.3.19

The iCub software requires that you install YARP first. YARP binaries are available here: http://www.yarp.it/installation_downloads.html

Windows

Win-logo.jpg
Important: to develop code using precompiled binaries packages have to match the compiler you use, make sure you download and install the correct version (i.e. MSVC12 x86 for Visual Studio 2013 32 bit, MSVC14/15 amd64 for Visual Studio 2015/2017 64 bit etc.).

If in doubt about the version number of your copy of Visual Studio, find the internal version number shown for it in this version history table.

iCub 1.8.0 MSVC 12 MSVC 14/15 Sources
x86 x86 x86 icub-main-src-1.8.0.zip
amd64 amd64 amd64 icub-main-src-1.8.0.zip

Linux

Linux-all.jpg
Binaries for Linux are available for Debian and Ubuntu with aptitude (see: Installation from pre-compiled binaries)

Packages

You can download individual .deb packages from Github:

iCub: https://github.com/robotology/icub-main/releases

Old Releases

In the past we moved from Sourceforge to GitHub, so some old releases can be found here: