Difference between revisions of "Downloads"

From Wiki for iCub and Friends
Jump to: navigation, search
 
(41 intermediate revisions by 6 users not shown)
Line 1: Line 1:
 
Latest releases:
 
Latest releases:
 
+
* 25/02/2018 : '''iCub-1.15.0''', requires '''YARP-3.3.2'''. Require [https://github.com/robotology/QA/issues/364 '''CMake 3.12'''].
* 10/07/2013, latest release: '''iCub-1.1.12''', requires '''YARP-2.3.21'''
 
  
 
Previous releases:
 
Previous releases:
 
+
* 22/10/2018 : iCub-1.12.0, requires YARP-3.1.0
* 04/03/2013: YARP 2.3.20 binaries for windows 64bits  
+
* 12/02/2018 : iCub-1.10.0, requires YARP-2.3.72
* 7/12/2012, latest release: '''iCub-1.1.11''', requires '''YARP-2.3.20''' (support for Visual Studio 11)
+
* 15/06/2017 : iCub-1.8.0, requires YARP-2.3.70
 +
* 29/11/2016 : iCub-1.6.0, requires YARP-2.3.68
 +
* 01/06/2016 : iCub-1.4.0, requires YARP-2.3.66
 +
* 18/06/2015 : iCub-1.1.16, requires YARP-2.3.64
 +
* 18/07/2014 : iCub-1.1.15, requires YARP-2.3.63
 +
* 06/08/2013 : iCub-1.1.13, requires YARP-2.3.22
 +
* 10/07/2013 : iCub-1.1.12, requires YARP-2.3.21
 +
* 04/03/2013 : YARP 2.3.20 binaries for windows 64bits  
 +
* 7/12/2012 : iCub-1.1.11, requires YARP-2.3.20 (support for Visual Studio 11)
 
* iCub-1.1.10, requires YARP-2.3.19
 
* iCub-1.1.10, requires YARP-2.3.19
  
 +
The iCub software requires that you install YARP first. YARP binaries are available here: http://www.yarp.it/installation_downloads.html
  
 
== Windows ==
 
== Windows ==
[[Image:win-logo.jpg|right|50px]] '''Important''': to develop code using precompiled binaries packages have to match the compiler you use, make sure you download and install the correct version (i.e. MSVC8 for Visual Studio 8, MSVC9 for Visual Studio 9 etc.).
+
[[Image:win-logo.jpg|right|50px]] '''Important''': to develop code using precompiled binaries packages have to match the compiler you use, make sure you download and install the correct version (i.e. MSVC12 x86 for Visual Studio 2013 32 bit, MSVC14/15 amd64 for Visual Studio 2015/2017 64 bit etc.).
  
If in doubt about the version number of your copy of Visual Studio, find the internal version number shown for it in this [http://en.wikipedia.org/wiki/Microsoft_Visual_Studio#Version_history version history table].
+
If in doubt about the version number of your copy of Visual Studio, find the internal version number shown for it in this [https://en.wikipedia.org/wiki/Microsoft_Visual_Studio#History version history table].
 
 
'''Latest Releases:'''
 
  
 
{| border="2" style="margin-left: 0em;"
 
{| border="2" style="margin-left: 0em;"
 
|-
 
|-
!
+
! iCub 1.15.0 and YARP 3.3.2 (from [https://github.com/robotology/robotology-superbuild Robotology Superbuild])
! scope="col" | MSVC 8
+
! scope="col" | Binaries (full install)
! scope="col" | MSVC 9
+
! scope="col" | Binaries (dependency only)
! scope="col" | MSVC 10
 
! scope="col" | MSVC 11
 
 
! scope="col" | Sources
 
! scope="col" | Sources
 
|-
 
|-
! scope="row" | iCub 1.1.12
+
! scope="row" | amd64
| [http://sourceforge.net/projects/robotcub/files/iCub-main/iCub-main-1.1.12/windows/iCub_1.1.12_v8_x86_0.exe x86]
+
| [https://github.com/robotology/robotology-superbuild/releases/download/v2020.02/robotology-full-installer-2020.02-win64.exe amd64]
| [http://sourceforge.net/projects/robotcub/files/iCub-main/iCub-main-1.1.12/windows/iCub_1.1.12_v9_x86_0.exe x86]
+
| [https://github.com/robotology/robotology-superbuild/releases/download/v2020.02/robotology-dependencies-installer-2020.02-win64.exe amd64]
| [http://sourceforge.net/projects/robotcub/files/iCub-main/iCub-main-1.1.12/windows/iCub_1.1.12_v10_x86_0.exe x86]
+
| [https://github.com/robotology/icub-main/archive/v1.15.0.zip icub-main-src-1.15.0.zip]
| [http://sourceforge.net/projects/robotcub/files/iCub-main/iCub-main-1.1.12/windows/iCub_1.1.12_v11_x86_0.exe x86]
 
| [http://sourceforge.net/projects/robotcub/files/iCub-main/iCub-main-1.1.12/iCub-main-src-1.1.12.zip iCub-main-src-1.1.12.zip]
 
|-
 
! scope="row" | YARP 2.3.21
 
| [http://sourceforge.net/projects/yarp0/files/yarp2/yarp-2.3.21/windows/yarp_2.3.21_v8_x86_0.exe/download x86]
 
| [http://sourceforge.net/projects/yarp0/files/yarp2/yarp-2.3.21/windows/yarp_2.3.21_v9_x86_0.exe/download x86]  [http://sourceforge.net/projects/yarp0/files/yarp2/yarp-2.3.21/windows/yarp_2.3.21_v9_x64_0.exe/download x64]
 
| [http://sourceforge.net/projects/yarp0/files/yarp2/yarp-2.3.21/windows/yarp_2.3.21_v10_x86_0.exe/download x86]  [http://sourceforge.net/projects/yarp0/files/yarp2/yarp-2.3.21/windows/yarp_2.21.20_v10_x64_0.exe/download x64]
 
| [http://sourceforge.net/projects/yarp0/files/yarp2/yarp-2.3.21/windows/yarp_2.3.21_v11_x86_0.exe/download x86] [http://sourceforge.net/projects/yarp0/files/yarp2/yarp-2.3.21/windows/yarp_2.3.21_v11_x64_0.exe/download x64]
 
| [http://downloads.sourceforge.net/yarp0/yarp-2.3.21.zip yarp-2.3.21.zip]
 
 
|}
 
|}
 
'''All versions:'''
 
 
iCub: https://sourceforge.net/projects/robotcub/files/iCub-main/
 
 
YARP: https://sourceforge.net/projects/yarp0/files/yarp2/
 
  
 
== Linux ==
 
== Linux ==
 
[[Image:linux-all.jpg|right|120px]] Binaries for Linux are available for Debian and Ubuntu with aptitude (see: [[Linux:Installation from binaries|Installation from pre-compiled binaries]])
 
[[Image:linux-all.jpg|right|120px]] Binaries for Linux are available for Debian and Ubuntu with aptitude (see: [[Linux:Installation from binaries|Installation from pre-compiled binaries]])
  
==== Sources ====
+
==== Packages ====
YARP: [http://downloads.sourceforge.net/yarp0/yarp-2.3.20.tar.gz yarp-2.3.20.tar.gz]
 
  
iCub: [http://sourceforge.net/projects/robotcub/files/iCub-main/iCub-main-1.1.11/iCub-main-src-1.1.11.tar.gz iCub-main-src-1.1.11.tar.gz]
+
You can download individual .deb packages from Github:
  
==== Packages ====
+
iCub: https://github.com/robotology/icub-main/releases
  
You can download individual .deb packages from sourceforge:
+
== Old Releases ==
  
YARP: https://sourceforge.net/projects/yarp0/files/yarp2/
+
''In the past we moved from Sourceforge to GitHub, so some old releases can be found here:''
  
iCub: https://sourceforge.net/projects/robotcub/files/iCub-main/
+
* iCub: https://sourceforge.net/projects/robotcub/files/iCub-main/

Latest revision as of 19:09, 27 February 2020

Latest releases:

  • 25/02/2018 : iCub-1.15.0, requires YARP-3.3.2. Require CMake 3.12.

Previous releases:

  • 22/10/2018 : iCub-1.12.0, requires YARP-3.1.0
  • 12/02/2018 : iCub-1.10.0, requires YARP-2.3.72
  • 15/06/2017 : iCub-1.8.0, requires YARP-2.3.70
  • 29/11/2016 : iCub-1.6.0, requires YARP-2.3.68
  • 01/06/2016 : iCub-1.4.0, requires YARP-2.3.66
  • 18/06/2015 : iCub-1.1.16, requires YARP-2.3.64
  • 18/07/2014 : iCub-1.1.15, requires YARP-2.3.63
  • 06/08/2013 : iCub-1.1.13, requires YARP-2.3.22
  • 10/07/2013 : iCub-1.1.12, requires YARP-2.3.21
  • 04/03/2013 : YARP 2.3.20 binaries for windows 64bits
  • 7/12/2012 : iCub-1.1.11, requires YARP-2.3.20 (support for Visual Studio 11)
  • iCub-1.1.10, requires YARP-2.3.19

The iCub software requires that you install YARP first. YARP binaries are available here: http://www.yarp.it/installation_downloads.html

Windows

Win-logo.jpg
Important: to develop code using precompiled binaries packages have to match the compiler you use, make sure you download and install the correct version (i.e. MSVC12 x86 for Visual Studio 2013 32 bit, MSVC14/15 amd64 for Visual Studio 2015/2017 64 bit etc.).

If in doubt about the version number of your copy of Visual Studio, find the internal version number shown for it in this version history table.

iCub 1.15.0 and YARP 3.3.2 (from Robotology Superbuild) Binaries (full install) Binaries (dependency only) Sources
amd64 amd64 amd64 icub-main-src-1.15.0.zip

Linux

Linux-all.jpg
Binaries for Linux are available for Debian and Ubuntu with aptitude (see: Installation from pre-compiled binaries)

Packages

You can download individual .deb packages from Github:

iCub: https://github.com/robotology/icub-main/releases

Old Releases

In the past we moved from Sourceforge to GitHub, so some old releases can be found here: