This website uses browsing/session and functional cookies to ensure you get the best experience. Learn More


From Wiki for iCub and Friends
Jump to: navigation, search

Latest releases:

  • 12/02/2018 : iCub-1.10.0, requires YARP-2.3.72

Previous releases:

  • 15/06/2017 : iCub-1.8.0, requires YARP-2.3.70
  • 29/11/2016 : iCub-1.6.0, requires YARP-2.3.68
  • 01/06/2016 : iCub-1.4.0, requires YARP-2.3.66
  • 18/06/2015 : iCub-1.1.16, requires YARP-2.3.64
  • 18/07/2014 : iCub-1.1.15, requires YARP-2.3.63
  • 06/08/2013 : iCub-1.1.13, requires YARP-2.3.22
  • 10/07/2013 : iCub-1.1.12, requires YARP-2.3.21
  • 04/03/2013 : YARP 2.3.20 binaries for windows 64bits
  • 7/12/2012 : iCub-1.1.11, requires YARP-2.3.20 (support for Visual Studio 11)
  • iCub-1.1.10, requires YARP-2.3.19

The iCub software requires that you install YARP first. YARP binaries are available here:


Important: to develop code using precompiled binaries packages have to match the compiler you use, make sure you download and install the correct version (i.e. MSVC12 x86 for Visual Studio 2013 32 bit, MSVC14/15 amd64 for Visual Studio 2015/2017 64 bit etc.).

If in doubt about the version number of your copy of Visual Studio, find the internal version number shown for it in this version history table.

iCub 1.10.0 MSVC 12 MSVC 14/15 Sources
x86 x86 x86
amd64 amd64 amd64


Binaries for Linux are available for Debian and Ubuntu with aptitude (see: Installation from pre-compiled binaries)


You can download individual .deb packages from Github:


Old Releases

In the past we moved from Sourceforge to GitHub, so some old releases can be found here: