Difference between revisions of "Homebrew"

From Wiki for iCub and Friends
Jump to: navigation, search
 
(gfortran (needed for ipopt))
Line 24: Line 24:
 
Reported by Ingo Keller:
 
Reported by Ingo Keller:
 
   following links I created after installing gfortran by "brew install gfortran".
 
   following links I created after installing gfortran by "brew install gfortran".
 
+
 
   ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortran.a /usr/local/lib/libgfortran.a
 
   ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortran.a /usr/local/lib/libgfortran.a
 
 
   ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortranbegin.a /usr/local/lib/libgfortranbegin.a
 
   ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortranbegin.a /usr/local/lib/libgfortranbegin.a
 
 
   ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortranbegin.la /usr/local/lib/libgfortranbegin.la
 
   ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortranbegin.la /usr/local/lib/libgfortranbegin.la
 
+
 
   The problem to the fix was an appearing of "-lgfortranbegin not found" while compiling ipopt depending modules.
 
   The problem to the fix was an appearing of "-lgfortranbegin not found" while compiling ipopt depending modules.

Revision as of 19:50, 27 July 2011

For Mac OSX, People now have most success with YARP/iCub using the homebrew package manager. If you are lucky, installing YARP could be as easy as:

 ruby -e "$(curl -fsSLk https://gist.github.com/raw/323731/install_homebrew.rb)"
 brew install yarp

Install homebrew

See http://mxcl.github.com/homebrew/ In summary: open a terminal (Applications->Utilities->Terminal), and do:

 ruby -e "$(curl -fsSLk https://gist.github.com/raw/323731/install_homebrew.rb)"

You should then be able to run commands like:

 brew help

To install many libraries (including YARP), you'll need to have XCode installed. It may also be necessary to move any "fink"/"macport" libraries out of the way, if you have used those package managers in the past. For example, if you have a "/sw" directory, consider moving it.

YARP

Install homebrew and XCode, then from a terminal do:

 brew install yarp

iCub

Glitches for various iCub dependencies now follow. Ideally, these glitches should get fixed "upstream"

gfortran (needed for ipopt)

Reported by Ingo Keller:

 following links I created after installing gfortran by "brew install gfortran".

 ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortran.a /usr/local/lib/libgfortran.a
 ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortranbegin.a /usr/local/lib/libgfortranbegin.a
 ln -s /usr/local/Cellar/gfortran/4.2.4-5664/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/libgfortranbegin.la /usr/local/lib/libgfortranbegin.la

 The problem to the fix was an appearing of "-lgfortranbegin not found" while compiling ipopt depending modules.