Difference between revisions of "NVidia CUDA Worksation installation instructions"

From Wiki for iCub and Friends
Jump to: navigation, search
(Install cuda toolkit =)
(Prerequisite : basic system setup for a iCub machine)
Line 7: Line 7:
 
Then, follow the below steps to customize it as the iCub Laptop
 
Then, follow the below steps to customize it as the iCub Laptop
  
''NOTE: in the following instructions, we assume that the installed OS is a Debian GNU/Linux Wheezy. if you are usign a different distribution os release, please modify the instructions accordingly.''
+
==''NOTE ==
 +
In the following instructions, we assume that the installed OS is a Debian GNU/Linux Wheezy. if you are usign a different distribution os release, please modify the instructions accordingly.''
  
 
== Install cuda toolkit  ==
 
== Install cuda toolkit  ==

Revision as of 11:36, 5 June 2015

This page contains guidelines to install the iCub nVidia CUDA Workstation.

We assume you have installed a working Debian or Ubuntu on the laptop. You can freely decide to install 32 bit or 64 bit, the code compiles on both architectures. Be aware that if you plan to share the repository with other machines, all machines need to have the same architecture (32 versus 64 bits, same versions of the libraries). A possibility would be to share the same code directory and different builds.

Prerequisite : basic system setup for a iCub machine

Please follow the instructions on page Generic iCub machine installation instructions, in order to prepare a generic machine for the iCub network. Then, follow the below steps to customize it as the iCub Laptop

NOTE

In the following instructions, we assume that the installed OS is a Debian GNU/Linux Wheezy. if you are usign a different distribution os release, please modify the instructions accordingly.

Install cuda toolkit

From debian non-free repository, install the following packages

 install nvidia-cuda-toolkit nvidia-cuda-dev

Install SiftGPU library and its dependancies =

  • get SiftGPU from | SiftGPU website
  • extract SiftGPU in /usr/loca/src/robot
  • install dependancies (DevIL and GLEW) as follows
apt-get install libdevil-dev libglew-dev
  • compile SiftGPU