Difference between revisions of "Which ACE version"

From Wiki for iCub and Friends
Jump to: navigation, search
 
Line 1: Line 1:
An important question is: which version of ACE should I install?
+
For the recommended version of ACE to install on each operating systems, check the robotology-superbuild documentation: https://github.com/robotology/robotology-superbuild .
 
 
We are not aware of any version of ACE that do not work with YARP and iCub.
 
 
 
The most tested version of ACE was 5.5.5. However this version is now outdated and start having problems with recent compilers, so we no longer recommend it (although it compiles fine at least with Visual Studio 8 and 9).
 
 
 
* Our test machines are using:
 
ACE 5.8.0 on Windows XP
 
ACE 5.5.5 on Debian Etch and Debian Lenny
 
ACE 6.0.1 on Ubuntu 9.10
 
 
 
See the machine description(small icon inside "Build name field") at http://dashboard.icub.org/index.php?project=YARP.
 
 
 
* We have successfully tested ACE 5.7 and ACE 6.0.1 on Windows XP.
 
 
 
* Precompiled versions of ACE on Debian Etch, Lenny and Ubuntu are known to work. We do our best to support them, so let us know if you encounter problems with them.
 

Latest revision as of 08:21, 5 October 2020

For the recommended version of ACE to install on each operating systems, check the robotology-superbuild documentation: https://github.com/robotology/robotology-superbuild .