Difference between revisions of "YARP on Mac"

From Wiki for iCub and Friends
Jump to: navigation, search
 
Line 1: Line 1:
If you have semaphore problems when running yarp programs, try this command:  
+
== Semaphore Issues ==
 +
If you get errors regarding semaphores when running yarp programs, try this command:  
  
 
   ulimit -n 4096
 
   ulimit -n 4096
  
 
(Add this to your startup script, like .bash_profile, to make it happen automatically for each new window.)
 
(Add this to your startup script, like .bash_profile, to make it happen automatically for each new window.)
 +
 +
== Installing Dependencies ==
 +
Using darwinports to install mac dependencies appears to work most of the time.

Revision as of 15:14, 21 July 2009

Semaphore Issues

If you get errors regarding semaphores when running yarp programs, try this command:

 ulimit -n 4096

(Add this to your startup script, like .bash_profile, to make it happen automatically for each new window.)

Installing Dependencies

Using darwinports to install mac dependencies appears to work most of the time.