This website uses browsing/session and functional cookies to ensure you get the best experience. Learn More

YARP Supported Distributions

From Wiki for iCub and Friends
Jump to: navigation, search

Contents


Supported releases

This is the list of the Linux distributions currently supported by YARP. This means that for these distributions we:

  • Supply .deb packages of new releases of YARP
  • We maintain test machines to ensure that the current sources in svn compile with that distribution (see: http://dashboard.icub.org)

The list of Linux distributions supported is updated using the Policy reported below.

Notice that we support both 64 and 32 bits versions.

Distribution Version Codename End of life cmake gcc-defaults ace gtk+2.0 gtkmm2.4 gsl opencv goocanvasmm gtkdataboxmm tinyxml libav ffmpeg libdc1394-22 Qt5†† coinor-ipopt swig2.0 swig
Debian [www] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] [pts][trk][lp] †† [pts][trk][lp] [pts][trk][lp] [pts][trk][lp]
Debian 9 Stretch (stable)* 3.6.2 1.163 (gcc 6.2.0) 6.3.3 2.24.31 2.24.5 2.2.1 2.4.9.1 N/A 0.9.4 2.6.2 N/A 3.2=libavcodec57,libavutil55 2.2.4 5.6.1 3.11.9 N/A 3.0.7
Debian 8 Jessie (oldstable) 3.0.2 1.136 (gcc 4.9.2) 6.2.8 2.24.25 2.24.4 1.16 2.4.9.1 0.15.4 0.9.4 2.6.2 11.3=libavcodec56,libavutil54 N/A (2.8.6=libavcodec56,libavutil54**) 2.2.3 5.3.2 3.11.9 2.0.12 3.0.2
Ubuntu [wiki] [lp] [lp] [lp] [lp] [lp] [lp] [lp] [lp] [lp] [lp] [lp] [lp] [lp] †† [lp] [lp] [lp]
Ubuntu 17.04 Zesty Zapus* 3.6.2 1.162 (gcc 6.1.1) 6.3.3 2.24.30 2.24.4 2.2.1 2.4.9.1 N/A 0.9.4 2.6.2 N/A 3.0.2=libavcodec57,libavutil55 2.2.4 5.6.1 3.11.9 N/A 3.0.8
Ubuntu 16.04 LTS Xenial Xerus 3.5.1 1.150 (gcc 5.3.1) 6.3.3 2.24.30 2.24.4 2.1 2.4.9.1 N/A 0.9.4 2.6.2 N/A 2.8.6=libavcodec56,libavutil54 2.2.4 5.5.1 3.11.9 2.0.12 3.0.8
Minimum version 3.0.2 1.150 (gcc 5.3.1) 6.2.8 2.24.30 2.24.4 1.16 2.4.9.1 N/A N/A 2.6.2 libavcodec53,libavutil51 (libavcodec54,libavutil52**) 2.1.2
Currently required 3.0 2.3.1-8† 1.x 5.2
*  Not yet officially supported/work in progress
** In backports, updates, security, or proposed repository
*** backports repository required
† OpenCV needs to be built with -DWITH_TBB. On Debian and Ubuntu this flag is used since 2.3.1-8
†† Qt5 packages:
   * qtbase-opensource-src: Debian [pts][trk][lp]
                            Ubuntu [lp]
   * qttools-opensource-src: Debian [pts][trk][lp]
                             Ubuntu [lp]
   * qtdeclarative-opensource-src: Debian [pts][trk][lp]
                                   Ubuntu [lp]
   * qtquickcontrols-opensource-src: Debian [pts][trk][lp]
                                     Ubuntu [lp]
   * qtmultimedia-opensource-src: Debian [pts][trk][lp]
                                  Ubuntu [lp]

Old releases

This is a list of releases no longer supported in trunk, with the latest YARP version officially supported.

Note that you might be able to build newer versions, but you will probably need to build some dependencies as well.

Distribution Version Codename YARP* cmake gcc-defaults ace gtk+2.0 gtkmm2.4 gsl opencv goocanvasmm gtkdataboxmm tinyxml libav ffmpeg libdc1392-22 Qt5 coinor-ipopt swig2.0 swig
Debian
Debian 7 Wheezy 2.3.68 2.8.9 (2.8.11.1**) 1.120 (gcc 4.7.2) 6.0.3 2.24.10 2.24.2 1.15 2.3.1-11 0.15.4 N/A 2.6.2 0.8.16=libavcodec53,libavutil51 (10.1=libavcodec55,libavutil53*) N/A 2.2.0 N/A (5.3.2**) 3.10.2 2.0.7 N/A
Debian 6 Squeeze 2.3.62 2.8.2 (2.8.9**) 4.4.5 5.7.7 2.20.1 2.20.3 1.14 2.1.0† 0.13.0 N/A 2.5.3  ? (0.8.6**) 0.5.10 2.1.2
Debian 5 Lenny 2.3.20 2.6.0 5.6.3 2.12.12 (2.20.1**) 2.12.7 1.11
Debian 4 Etch 2.3.20 2.4.5 (2.6.0**) 5.4.7 1.8 1.1.0 (libdc1932)
Ubuntu
Ubuntu 16.10 Yakkety Yak 2.3.70 3.5.2 1.162 (gcc 6.1.1) 6.3.3 2.24.30 2.24.5 2.1 2.4.9.1 N/A 0.9.4 2.6.2 N/A 3.0.2=libavcodec57,libavutil55 2.2.4 5.6.1 3.11.9 N/A 3.0.8
Ubuntu 15.10 Wily Werewolf 2.3.66 3.2.2 1.144 (gcc 5.2.1) 6.2.8 2.24.28 2.24.4 1.16 2.4.9 N/A 0.9.4 2.6.2 N/A 2.7.2=libavcodec56,libavutil54 (2.7.6=libavcodec56,libavutil54**) 2.2.3 5.4.2 3.11.9 2.0.12 3.0.2
Ubuntu 15.04 Vivid Vervet 2.3.65 3.0.2 1.136 (gcc 4.9.2) 6.2.8 2.24.25 2.24.4 1.16 2.4.9 0.15.4 0.9.4 2.6.2 11.2=libavcodec56,libavutil54 2.5.4=libavcodec56,libavutil54 (2.5.7=libavcodec56,libavutil54**) 2.2.3 5.4.1 3.11.9 2.0.12 3.0.2
Ubuntu 14.10 Utopic Unicorn 2.3.64 2.8.12.2 4.9.1 6.0.3 2.24.24 2.24.4 1.16 2.4.8 0.15.4 0.9.4 2.6.2 11=libavcodec56 N/A 2.2.1 5.3.0 3.11.7 2.0.12 3.0.2
Ubuntu 14.04 LTS Trusty Tahr 2.3.68 2.8.12.2 1.124 (gcc 4.8.2) 6.0.3 2.24.23 2.24.4 1.16 2.4.8 0.15.4 0.9.4 2.6.2 9.11=libavcodec54,libavutil52 (9.18=libavcodec54,libavutil52**) N/A 2.2.1 5.2.1 3.11.4 2.0.11 3.0.2**
Ubuntu 13.10 Saucy Salamander 2.3.63 2.8.11.2 4.8.1 6.0.3 2.24.20 2.24.4 1.16 2.4.5 0.15.4 0.9.4 2.6.2 0.8.6 (0.8.7**) 2.2.1 5.0.2
Ubuntu 13.04 Raring Ringtail 2.3.62 2.8.10.1 4.7.3 6.0.3 2.24.17 2.24.2 1.15 2.4.2 0.15.4 N/A 2.6.2 0.8.6 2.2.0
Ubuntu 12.10 Quantal Quetzal 2.3.62 2.8.9 4.7.2 6.0.3 2.24.13 2.24.2 1.15 2.3.1-11 0.15.4 N/A 2.6.2 0.8.3 (0.8.6**) 2.2.0
Ubuntu 12.04 LTS Precise Pangolin 2.3.62 2.8.7 4.6.3 6.0.1 2.24.10 2.24.2 1.15 2.3.1-7† 0.15.4 N/A 2.6.2 0.8.1 (0.8.6**) 2.2.0
Ubuntu 11.10 Oneiric Ocelot 2.3.20 2.8.5 2.24.6 2.24.2 1.15 2.1.3
Ubuntu 11.04 Natty Narwhal 2.3.20
Ubuntu 10.10 Maverick Meerkat 2.3.20
Ubuntu 10.04 LTS Lucid Lynx 2.3.20 2.8.0 (2.8.1**) 5.6.3 2.20.0 (2.20.1**) 2.20.2 (2.20.3**) 1.13 2.0.0 0.15.0 N/A
Ubuntu 9.10 Karmic Koala 2.3.20
Ubuntu 9.04 Jaunty Jackalope 2.3.20
Ubuntu 8.10 Intrepid Ibex 2.3.20
Ubuntu 8.04 LTS Hardy Heron 2.3.20 2.4.7 (2.6.2**) 2.12.9 2.12.5 1.10 1.1.0 (libdc1394)
*  Latest YARP version officially supported
** In backports or updates repository

Policy

In order to reduce the effort to maintain all the releases supported by Debian and Ubuntu, YARP supports officially only a limited number of releases. This policy is intended to support a good amount of releases, but, at the same time, to enable developers to use newer features in the dependencies (by supporting all the releases we would be bound to ~5 years old versions)

These are the releases supported:

Debian testing
Supported always.
Debian stable
Supported always.
Debian oldstable
Supported only for either 3 or 6 months after a stable release (i.e. starting when the old "stable" becomes "oldstable"), in order to give some time to the users to upgrade their system.
Ubuntu short term releases
Supported only until Canonical supports them.
Ubuntu long term releases
Only the latest one is supported. When a new long term release is released, we support the previous one for either 3 or 6 extra months, in order to give some time to the users to upgrade their system.
All the other releases
Not supported


Dropping support doesn't mean that the next releases won't necessarily build on that specific version, but:

  • If we need a newer version for a package, we upgrade it.
  • We don't supply .deb packages of newer releases for those versions.
  • We remove the build machines for that release from the dashboard.

Useful links

Personal tools
Namespaces

Variants
Actions
Navigation
Print/export
Toolbox